gnu: linux-firmware: Update to 20231111.

* nongnu/packages/linux.scm (linux-firmware): Update to 20231111.
[source]: Add patch.
* nongnu/packages/patches/copy-firmware-rdfind.patch: New file.

Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
This commit is contained in:
Ada Stevenson 2023-11-13 14:46:12 +08:00 committed by John Kehayias
parent 621ca1767c
commit 170c52a7cf
No known key found for this signature in database
GPG key ID: 499097AE5EA815D9
2 changed files with 36 additions and 2 deletions

View file

@ -23,6 +23,7 @@
;;; Copyright © 2023 Jelle Licht <jlicht@fsfe.org> ;;; Copyright © 2023 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2023 Adam Kandur <rndd@tuta.io> ;;; Copyright © 2023 Adam Kandur <rndd@tuta.io>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space> ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Ada Stevenson <adanskana@gmail.com>
(define-module (nongnu packages linux) (define-module (nongnu packages linux)
#:use-module (gnu packages) #:use-module (gnu packages)
@ -247,14 +248,16 @@ stable, responsive and smooth desktop experience."))))
(define-public linux-firmware (define-public linux-firmware
(package (package
(name "linux-firmware") (name "linux-firmware")
(version "20231030") (version "20231111")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/firmware/" (uri (string-append "mirror://kernel.org/linux/kernel/firmware/"
"linux-firmware-" version ".tar.xz")) "linux-firmware-" version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"1ivrasi3p1l7sd73m21yybgijn0k9vikqwcllphhs4m3qh7j13f9")))) "165hrdwfvkqngmdf5s759wzfk8wpa8h6bln31bjady1z570mjjcd"))
(patches
(search-patches "nongnu/packages/patches/copy-firmware-rdfind.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
`(#:tests? #f `(#:tests? #f

View file

@ -0,0 +1,31 @@
diff --git a/copy-firmware.sh b/copy-firmware.sh
index f9b1f0ff..de28e882 100755
--- a/copy-firmware.sh
+++ b/copy-firmware.sh
@@ -69,11 +69,6 @@ if [ -z "$destdir" ]; then
exit 1
fi
-if ! which rdfind 2>/dev/null >/dev/null; then
- echo "ERROR: rdfind is not installed"
- exit 1
-fi
-
# shellcheck disable=SC2162 # file/folder name can include escaped symbols
grep -E '^(RawFile|File):' WHENCE | sed -E -e 's/^(RawFile|File): */\1 /;s/"//g' | while read k f; do
test -f "$f" || continue
@@ -87,14 +82,6 @@ grep -E '^(RawFile|File):' WHENCE | sed -E -e 's/^(RawFile|File): */\1 /;s/"//g'
fi
done
-$verbose "Finding duplicate files"
-rdfind -makesymlinks true -makeresultsfile false "$destdir" >/dev/null
-find "$destdir" -type l | while read -r l; do
- target="$(realpath "$l")"
- $verbose "Correcting path for $l"
- ln -fs "$(realpath --relative-to="$(dirname "$(realpath -s "$l")")" "$target")" "$l"
-done
-
# shellcheck disable=SC2162 # file/folder name can include escaped symbols
grep -E '^Link:' WHENCE | sed -e 's/^Link: *//g;s/-> //g' | while read f d; do
if test -L "$f$compext"; then