nongnu: broadcom-sta: Fix build on linux 5.9 and later.

* nongnu/packages/linux.scm (broadcom-sta-x86_64-source)[patches]: Use
patch.
* nongnu/packages/patches/broadcom-sta-linux-5.9.patch: New patch from
Arch Linux (without already applied hunks).

Closes https://gitlab.com/nonguix/nonguix/-/merge_requests/55.
Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
This commit is contained in:
James Smith 2020-10-25 13:36:28 -07:00 committed by Jonathan Brielmaier
parent 9256536ad2
commit 9efcb6799c
No known key found for this signature in database
GPG key ID: ECFC83988B4E4B9F
2 changed files with 14 additions and 1 deletions

View file

@ -558,7 +558,8 @@ package contains nonfree firmware for the following chips:
"broadcom-sta-fix_mac_profile_discrepancy.patch"
"broadcom-sta-linux-5.1.patch"
;; source: https://github.com/NixOS/nixpkgs/commit/8ce65087c333097ab714d23800b69fc471ec48ca
"broadcom-sta-linux-5.6.patch")))
"broadcom-sta-linux-5.6.patch"
"broadcom-sta-linux-5.9.patch")))
(sha256
(base32
"1gj485qqr190idilacpxwgqyw21il03zph2rddizgj7fbd6pfyaz"))))

View file

@ -0,0 +1,12 @@
diff -u -r a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
--- a/src/wl/sys/wl_linux.c 2020-10-12 21:19:15.256305165 +0000
+++ b/src/wl/sys/wl_linux.c 2020-10-12 21:20:38.687530895 +0000
@@ -1643,7 +1643,7 @@
goto done2;
}
- if (segment_eq(get_fs(), KERNEL_DS))
+ if (get_fs().seg == KERNEL_DS.seg)
buf = ioc.buf;
else if (ioc.buf) {