From a952c73019d4cd46dc202bcdd09bcf44a31f8c1a Mon Sep 17 00:00:00 2001
From: Josselin Poiret <dev@jpoiret.xyz>
Date: Tue, 8 Feb 2022 15:52:15 +0100
Subject: [PATCH] nongnu: Add i915-firmware.

* nongnu/packages/linux.scm (i915-firmware): New variable.

Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
---
 nongnu/packages/linux.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index a52b4be..0f9b0d9 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2021 Risto Stevcev <me@risto.codes>
 ;;; Copyright © 2021 aerique <aerique@xs4all.nl>
+;;; Copyright © 2022 Josselin Poiret <dev@jpoiret.xyz>
 ;;;
 ;;; This program is free software: you can redistribute it and/or modify
 ;;; it under the terms of the GNU General Public License as published by
@@ -418,6 +419,26 @@ support for 5GHz and 802.11ac, among others.")
                "https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
                "/linux-firmware.git/plain/LICENCE.iwlwifi_firmware")))))
 
+(define-public i915-firmware
+  (package
+    (inherit linux-firmware)
+    (name "i915-firmware")
+    (arguments
+     `(#:license-file-regexp "LICENCE.i915"
+       ,@(substitute-keyword-arguments (package-arguments linux-firmware)
+           ((#:phases phases)
+            `(modify-phases ,phases
+               (add-after 'unpack 'select-firmware
+                 ,(select-firmware "^i915/")))))))
+    (home-page "https://01.org/linuxgraphics/gfx-docs/drm/gpu/i915.html")
+    (synopsis "Nonfree firmware for Intel integrated graphics")
+    (description "This package contains the various firmware for Intel
+integrated graphics chipsets, including GuC, HuC and DMC.")
+    (license
+     (nonfree (string-append
+               "https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
+               "/linux-firmware.git/plain/LICENCE.i915")))))
+
 (define-public realtek-firmware
   (package
     (inherit linux-firmware)