nongnu: linux-firmware: Update to 20231211.

* nongnu/packages/linux.scm (linux-firmware): Update to 20231211.
[source]: Remove no longer needed patch.
[arguments]: Replace 'install phase to not call rdfind.
* nongnu/packages/patches/copy-firmware-rdfind.patch: Remove file.

Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
This commit is contained in:
Ada Stevenson 2023-12-20 14:33:37 +08:00 committed by Jonathan Brielmaier
parent 75541ecc29
commit f0c8465ed2
No known key found for this signature in database
GPG key ID: ECFC83988B4E4B9F
2 changed files with 5 additions and 35 deletions

View file

@ -245,22 +245,23 @@ stable, responsive and smooth desktop experience."))))
(define-public linux-firmware (define-public linux-firmware
(package (package
(name "linux-firmware") (name "linux-firmware")
(version "20231111") (version "20231211")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/firmware/" (uri (string-append "mirror://kernel.org/linux/kernel/firmware/"
"linux-firmware-" version ".tar.xz")) "linux-firmware-" version ".tar.xz"))
(sha256 (sha256
(base32 (base32
"165hrdwfvkqngmdf5s759wzfk8wpa8h6bln31bjady1z570mjjcd")) "1fz8vflidayal6gpjvmp75ni04b9ndxbpp5krmlpilxbbr5pxbwn"))))
(patches
(search-patches "nongnu/packages/patches/copy-firmware-rdfind.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
`(#:tests? #f `(#:tests? #f
#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))) #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
#:phases #:phases
(modify-phases %standard-phases (modify-phases %standard-phases
(replace 'install
(lambda* (#:key (make-flags '()) #:allow-other-keys)
(apply invoke "make" "install-nodedup" make-flags)))
(delete 'validate-runpath)))) (delete 'validate-runpath))))
(home-page (home-page
"https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git") "https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git")

View file

@ -1,31 +0,0 @@
diff --git a/copy-firmware.sh b/copy-firmware.sh
index f9b1f0ff..de28e882 100755
--- a/copy-firmware.sh
+++ b/copy-firmware.sh
@@ -69,11 +69,6 @@ if [ -z "$destdir" ]; then
exit 1
fi
-if ! which rdfind 2>/dev/null >/dev/null; then
- echo "ERROR: rdfind is not installed"
- exit 1
-fi
-
# shellcheck disable=SC2162 # file/folder name can include escaped symbols
grep -E '^(RawFile|File):' WHENCE | sed -E -e 's/^(RawFile|File): */\1 /;s/"//g' | while read k f; do
test -f "$f" || continue
@@ -87,14 +82,6 @@ grep -E '^(RawFile|File):' WHENCE | sed -E -e 's/^(RawFile|File): */\1 /;s/"//g'
fi
done
-$verbose "Finding duplicate files"
-rdfind -makesymlinks true -makeresultsfile false "$destdir" >/dev/null
-find "$destdir" -type l | while read -r l; do
- target="$(realpath "$l")"
- $verbose "Correcting path for $l"
- ln -fs "$(realpath --relative-to="$(dirname "$(realpath -s "$l")")" "$target")" "$l"
-done
-
# shellcheck disable=SC2162 # file/folder name can include escaped symbols
grep -E '^Link:' WHENCE | sed -e 's/^Link: *//g;s/-> //g' | while read f d; do
if test -L "$f$compext"; then