mirror of
https://gitlab.com/nonguix/nonguix.git
synced 2024-11-22 16:38:09 +01:00
170c52a7cf
* nongnu/packages/linux.scm (linux-firmware): Update to 20231111. [source]: Add patch. * nongnu/packages/patches/copy-firmware-rdfind.patch: New file. Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
diff --git a/copy-firmware.sh b/copy-firmware.sh
|
|
index f9b1f0ff..de28e882 100755
|
|
--- a/copy-firmware.sh
|
|
+++ b/copy-firmware.sh
|
|
@@ -69,11 +69,6 @@ if [ -z "$destdir" ]; then
|
|
exit 1
|
|
fi
|
|
|
|
-if ! which rdfind 2>/dev/null >/dev/null; then
|
|
- echo "ERROR: rdfind is not installed"
|
|
- exit 1
|
|
-fi
|
|
-
|
|
# shellcheck disable=SC2162 # file/folder name can include escaped symbols
|
|
grep -E '^(RawFile|File):' WHENCE | sed -E -e 's/^(RawFile|File): */\1 /;s/"//g' | while read k f; do
|
|
test -f "$f" || continue
|
|
@@ -87,14 +82,6 @@ grep -E '^(RawFile|File):' WHENCE | sed -E -e 's/^(RawFile|File): */\1 /;s/"//g'
|
|
fi
|
|
done
|
|
|
|
-$verbose "Finding duplicate files"
|
|
-rdfind -makesymlinks true -makeresultsfile false "$destdir" >/dev/null
|
|
-find "$destdir" -type l | while read -r l; do
|
|
- target="$(realpath "$l")"
|
|
- $verbose "Correcting path for $l"
|
|
- ln -fs "$(realpath --relative-to="$(dirname "$(realpath -s "$l")")" "$target")" "$l"
|
|
-done
|
|
-
|
|
# shellcheck disable=SC2162 # file/folder name can include escaped symbols
|
|
grep -E '^Link:' WHENCE | sed -e 's/^Link: *//g;s/-> //g' | while read f d; do
|
|
if test -L "$f$compext"; then
|