mirror of
https://gitlab.com/nonguix/nonguix.git
synced 2024-12-23 23:34:52 +01:00
4fe0608a5c
* nongnu/packages/patches/firefox-esr-compare-paths.patch: New file. * nongnu/packages/patches/firefox-esr-use-system-wide-dir.patch: New file. * nongnu/packages/mozilla.scm (firefox-esr)[source]: Add them. [arguments]<#:configure-flags>: Allow unsigned system addons. [native-search-paths]: Add ICECAT_SYSTEM_DIR.
23 lines
987 B
Diff
23 lines
987 B
Diff
See comment in gnu/build/icecat-extension.scm.
|
|
|
|
diff --git a/toolkit/mozapps/extensions/internal/XPIDatabase.sys.mjs b/toolkit/mozapps/extensions/internal/XPIDatabase.sys.mjs
|
|
index 0b885f6..0bbfbee 100644
|
|
--- a/toolkit/mozapps/extensions/internal/XPIDatabase.sys.mjs
|
|
+++ b/toolkit/mozapps/extensions/internal/XPIDatabase.sys.mjs
|
|
@@ -3607,6 +3607,7 @@ export const XPIDatabaseReconcile = {
|
|
if (
|
|
newAddon ||
|
|
oldAddon.updateDate != xpiState.mtime ||
|
|
+ oldAddon.path != xpiState.path ||
|
|
(aUpdateCompatibility && this.isAppBundledLocation(installLocation))
|
|
) {
|
|
newAddon = this.updateMetadata(
|
|
@@ -3615,8 +3616,6 @@ export const XPIDatabaseReconcile = {
|
|
xpiState,
|
|
newAddon
|
|
);
|
|
- } else if (oldAddon.path != xpiState.path) {
|
|
- newAddon = this.updatePath(installLocation, oldAddon, xpiState);
|
|
} else if (aUpdateCompatibility || aSchemaChange) {
|
|
newAddon = this.updateCompatibility(
|
|
installLocation,
|