mirror of
https://gitlab.com/nonguix/nonguix.git
synced 2024-11-23 17:08:09 +01:00
5b9fbf9474
* nongnu/packages/linux.scm (broadcom-sta): New variable. * nongnu/packages/patches/broadcom-sta-debian-fix-kernel-warnings.patch: New file. * nongnu/packages/patches/broadcom-sta-fix_mac_profile_discrepancy.patch: New file. * nongnu/packages/patches/broadcom-sta-gcc.patch: New file. * nongnu/packages/patches/broadcom-sta-license.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.11.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.12.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.15.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.7.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.8.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-5.1.patch: New file. * nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch: New file. * nongnu/packages/patches/broadcom-sta-rdtscl.patch: New file.
64 lines
1.8 KiB
Diff
64 lines
1.8 KiB
Diff
From d3f93542326a06d920c6eb89b703384290d37b8b Mon Sep 17 00:00:00 2001
|
|
From: Alberto Milone <alberto.milone@canonical.com>
|
|
Date: Fri, 2 Sep 2016 17:35:34 +0200
|
|
Subject: [PATCH 1/1] Add support for Linux 4.8
|
|
|
|
Orginal author: Krzysztof Kolasa
|
|
---
|
|
src/wl/sys/wl_cfg80211_hybrid.c | 22 ++++++++++++++++++++++
|
|
1 file changed, 22 insertions(+)
|
|
|
|
diff --git a/src/wl/sys/wl_cfg80211_hybrid.c b/src/wl/sys/wl_cfg80211_hybrid.c
|
|
index 2fc71fe..ec5e472 100644
|
|
--- a/src/wl/sys/wl_cfg80211_hybrid.c
|
|
+++ b/src/wl/sys/wl_cfg80211_hybrid.c
|
|
@@ -2388,8 +2388,16 @@ wl_bss_connect_done(struct wl_cfg80211_priv *wl, struct net_device *ndev,
|
|
s32 err = 0;
|
|
|
|
if (wl->scan_request) {
|
|
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
|
|
+ struct cfg80211_scan_info info = {
|
|
+ .aborted = true,
|
|
+ };
|
|
+ WL_DBG(("%s: Aborting scan\n", __FUNCTION__));
|
|
+ cfg80211_scan_done(wl->scan_request, &info);
|
|
+#else
|
|
WL_DBG(("%s: Aborting scan\n", __FUNCTION__));
|
|
cfg80211_scan_done(wl->scan_request, true);
|
|
+#endif
|
|
wl->scan_request = NULL;
|
|
}
|
|
|
|
@@ -2490,7 +2498,14 @@ wl_notify_scan_status(struct wl_cfg80211_priv *wl, struct net_device *ndev,
|
|
|
|
scan_done_out:
|
|
if (wl->scan_request) {
|
|
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
|
|
+ struct cfg80211_scan_info info = {
|
|
+ .aborted = false,
|
|
+ };
|
|
+ cfg80211_scan_done(wl->scan_request, &info);
|
|
+#else
|
|
cfg80211_scan_done(wl->scan_request, false);
|
|
+#endif
|
|
wl->scan_request = NULL;
|
|
}
|
|
rtnl_unlock();
|
|
@@ -2909,7 +2924,14 @@ s32 wl_cfg80211_down(struct net_device *ndev)
|
|
s32 err = 0;
|
|
|
|
if (wl->scan_request) {
|
|
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
|
|
+ struct cfg80211_scan_info info = {
|
|
+ .aborted = true,
|
|
+ };
|
|
+ cfg80211_scan_done(wl->scan_request, &info);
|
|
+#else
|
|
cfg80211_scan_done(wl->scan_request, true);
|
|
+#endif
|
|
wl->scan_request = NULL;
|
|
}
|
|
|
|
--
|
|
2.7.4
|
|
|