mirror of
https://gitlab.com/nonguix/nonguix.git
synced 2024-11-23 17:08:09 +01:00
5b9fbf9474
* nongnu/packages/linux.scm (broadcom-sta): New variable. * nongnu/packages/patches/broadcom-sta-debian-fix-kernel-warnings.patch: New file. * nongnu/packages/patches/broadcom-sta-fix_mac_profile_discrepancy.patch: New file. * nongnu/packages/patches/broadcom-sta-gcc.patch: New file. * nongnu/packages/patches/broadcom-sta-license.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.11.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.12.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.15.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.7.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.8.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-5.1.patch: New file. * nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch: New file. * nongnu/packages/patches/broadcom-sta-rdtscl.patch: New file.
27 lines
667 B
Diff
27 lines
667 B
Diff
Description: Fixing null pointer crash
|
|
|
|
Origin: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773713
|
|
Bug-Ubuntu: https://launchpad.net/bugs/1415880
|
|
Last-Update: 2015-08-18
|
|
|
|
---
|
|
src/wl/sys/wl_linux.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
|
|
index 860b935..295156f 100644
|
|
--- a/src/wl/sys/wl_linux.c
|
|
+++ b/src/wl/sys/wl_linux.c
|
|
@@ -2157,8 +2157,8 @@ wl_start(struct sk_buff *skb, struct net_device *dev)
|
|
wlif = WL_DEV_IF(dev);
|
|
wl = WL_INFO(dev);
|
|
|
|
+ skb->prev = NULL;
|
|
if (WL_ALL_PASSIVE_ENAB(wl) || (WL_RTR() && WL_CONFIG_SMP())) {
|
|
- skb->prev = NULL;
|
|
|
|
TXQ_LOCK(wl);
|
|
|
|
--
|
|
1.9.1
|
|
|