nonguix/nongnu/packages/patches/broadcom-sta-linux-4.15.patch
Alex Griffin 5b9fbf9474 nongnu: Add broadcom-sta.
* nongnu/packages/linux.scm (broadcom-sta): New variable.
* nongnu/packages/patches/broadcom-sta-debian-fix-kernel-warnings.patch: New file.
* nongnu/packages/patches/broadcom-sta-fix_mac_profile_discrepancy.patch: New file.
* nongnu/packages/patches/broadcom-sta-gcc.patch: New file.
* nongnu/packages/patches/broadcom-sta-license.patch: New file.
* nongnu/packages/patches/broadcom-sta-linux-4.11.patch: New file.
* nongnu/packages/patches/broadcom-sta-linux-4.12.patch: New file.
* nongnu/packages/patches/broadcom-sta-linux-4.15.patch: New file.
* nongnu/packages/patches/broadcom-sta-linux-4.7.patch: New file.
* nongnu/packages/patches/broadcom-sta-linux-4.8.patch: New file.
* nongnu/packages/patches/broadcom-sta-linux-5.1.patch: New file.
* nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch: New file.
* nongnu/packages/patches/broadcom-sta-rdtscl.patch: New file.
2019-05-30 05:43:32 -05:00

47 lines
1.1 KiB
Diff

See: https://lkml.org/lkml/2017/11/25/90
diff -urNZ a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
--- a/src/wl/sys/wl_linux.c 2015-09-18 22:47:30.000000000 +0000
+++ b/src/wl/sys/wl_linux.c 2018-01-31 22:52:10.859856221 +0000
@@ -93,7 +93,11 @@
#include <wlc_wowl.h>
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
+static void wl_timer(struct timer_list *tl);
+#else
static void wl_timer(ulong data);
+#endif
static void _wl_timer(wl_timer_t *t);
static struct net_device *wl_alloc_linux_if(wl_if_t *wlif);
@@ -2298,9 +2302,15 @@
}
static void
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
+wl_timer(struct timer_list *tl)
+{
+ wl_timer_t *t = from_timer(t, tl, timer);
+#else
wl_timer(ulong data)
{
wl_timer_t *t = (wl_timer_t *)data;
+#endif
if (!WL_ALL_PASSIVE_ENAB(t->wl))
_wl_timer(t);
@@ -2352,9 +2362,13 @@
bzero(t, sizeof(wl_timer_t));
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
+ timer_setup(&t->timer, wl_timer, 0);
+#else
init_timer(&t->timer);
t->timer.data = (ulong) t;
t->timer.function = wl_timer;
+#endif
t->wl = wl;
t->fn = fn;
t->arg = arg;