mirror of
https://gitlab.com/nonguix/nonguix.git
synced 2024-11-23 17:08:09 +01:00
5b9fbf9474
* nongnu/packages/linux.scm (broadcom-sta): New variable. * nongnu/packages/patches/broadcom-sta-debian-fix-kernel-warnings.patch: New file. * nongnu/packages/patches/broadcom-sta-fix_mac_profile_discrepancy.patch: New file. * nongnu/packages/patches/broadcom-sta-gcc.patch: New file. * nongnu/packages/patches/broadcom-sta-license.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.11.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.12.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.15.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.7.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.8.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-5.1.patch: New file. * nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch: New file. * nongnu/packages/patches/broadcom-sta-rdtscl.patch: New file.
16 lines
531 B
Diff
16 lines
531 B
Diff
https://bugs.archlinux.org/task/61090
|
|
|
|
--- a/src/wl/sys/wl_cfg80211_hybrid.c 2015-09-19 00:47:30.000000000 +0200
|
|
+++ b/src/wl/sys/wl_cfg80211_hybrid.c 2018-11-14 14:06:03.313487995 +0100
|
|
@@ -1444,11 +1444,10 @@
|
|
s32 rate;
|
|
s32 err = 0;
|
|
|
|
if (memcmp(mac, wl->profile->bssid, ETHER_ADDR_LEN)) {
|
|
WL_ERR(("Wrong Mac address, mac = %pM profile =%pM\n", mac, wl->profile->bssid));
|
|
- return -ENOENT;
|
|
}
|
|
|
|
err = wl_dev_ioctl(dev, WLC_GET_RATE, &rate, sizeof(rate));
|
|
if (err) {
|
|
WL_DBG(("Could not get rate (%d)\n", err));
|