nonguix/nongnu/packages/patches/broadcom-sta-linux-5.9.patch
James Smith 9efcb6799c
nongnu: broadcom-sta: Fix build on linux 5.9 and later.
* nongnu/packages/linux.scm (broadcom-sta-x86_64-source)[patches]: Use
patch.
* nongnu/packages/patches/broadcom-sta-linux-5.9.patch: New patch from
Arch Linux (without already applied hunks).

Closes https://gitlab.com/nonguix/nonguix/-/merge_requests/55.
Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
2020-10-26 08:26:26 +01:00

12 lines
348 B
Diff

diff -u -r a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
--- a/src/wl/sys/wl_linux.c 2020-10-12 21:19:15.256305165 +0000
+++ b/src/wl/sys/wl_linux.c 2020-10-12 21:20:38.687530895 +0000
@@ -1643,7 +1643,7 @@
goto done2;
}
- if (segment_eq(get_fs(), KERNEL_DS))
+ if (get_fs().seg == KERNEL_DS.seg)
buf = ioc.buf;
else if (ioc.buf) {