mirror of
https://gitlab.com/nonguix/nonguix.git
synced 2025-01-08 07:01:42 +01:00
e81013943d
* nongnu/packages/patches/firefox-use-system-wide-dir.patch: New file. * nongnu/packages/mozilla.scm (firefox)[source]: Add it along with firefox-esr-compare-paths.patch.
37 lines
1.3 KiB
Diff
37 lines
1.3 KiB
Diff
Replace "/usr/lib/mozilla" (the system-wide directory for extensions and
|
|
native manifests) with "$ICECAT_SYSTEM_DIR".
|
|
|
|
diff --git a/toolkit/xre/nsXREDirProvider.cpp b/toolkit/xre/nsXREDirProvider.cpp
|
|
index e3be04e70c..a3501c4f44 100644
|
|
--- a/toolkit/xre/nsXREDirProvider.cpp
|
|
+++ b/toolkit/xre/nsXREDirProvider.cpp
|
|
@@ -280,24 +280,11 @@ nsresult nsXREDirProvider::GetBackgroundTasksProfilesRootDir(
|
|
static nsresult GetSystemParentDirectory(nsIFile** aFile) {
|
|
nsresult rv;
|
|
nsCOMPtr<nsIFile> localDir;
|
|
-# if defined(XP_MACOSX)
|
|
- rv = GetOSXFolderType(kOnSystemDisk, kApplicationSupportFolderType,
|
|
- getter_AddRefs(localDir));
|
|
- if (NS_SUCCEEDED(rv)) {
|
|
- rv = localDir->AppendNative("Mozilla"_ns);
|
|
- }
|
|
-# else
|
|
- constexpr auto dirname =
|
|
-# ifdef HAVE_USR_LIB64_DIR
|
|
- "/usr/lib64/mozilla"_ns
|
|
-# elif defined(__OpenBSD__) || defined(__FreeBSD__)
|
|
- "/usr/local/lib/mozilla"_ns
|
|
-# else
|
|
- "/usr/lib/mozilla"_ns
|
|
-# endif
|
|
- ;
|
|
- rv = NS_NewNativeLocalFile(dirname, getter_AddRefs(localDir));
|
|
-# endif
|
|
+ const char* systemParentDir = getenv("ICECAT_SYSTEM_DIR");
|
|
+ if (!systemParentDir || !*systemParentDir) return NS_ERROR_FAILURE;
|
|
+
|
|
+ rv = NS_NewNativeLocalFile(nsDependentCString(systemParentDir),
|
|
+ getter_AddRefs(localDir));
|
|
|
|
if (NS_SUCCEEDED(rv)) {
|
|
localDir.forget(aFile);
|