mirror of
https://git.notmuchmail.org/git/notmuch
synced 2024-11-21 18:38:08 +01:00
Merge branch 'release'
This commit is contained in:
commit
1331888374
10 changed files with 71 additions and 30 deletions
|
@ -36,7 +36,6 @@ endif
|
|||
endif
|
||||
|
||||
UPSTREAM_TAG=$(subst ~,_,$(VERSION))
|
||||
DEB_TAG=debian/$(UPSTREAM_TAG)-1
|
||||
|
||||
RELEASE_HOST=notmuchmail.org
|
||||
RELEASE_DIR=/srv/notmuchmail.org/www/releases
|
||||
|
|
|
@ -73,12 +73,11 @@ release: verify-source-tree-and-version
|
|||
$(MAKE) VERSION=$(VERSION) $(SHA256_FILE) $(DETACHED_SIG_FILE)
|
||||
ln -sf $(TAR_FILE) $(DEB_TAR_FILE)
|
||||
pristine-tar commit $(DEB_TAR_FILE) $(UPSTREAM_TAG)
|
||||
git tag -s -m "$(PACKAGE) Debian $(VERSION)-1 upload (same as $(VERSION))" $(DEB_TAG)
|
||||
mkdir -p releases
|
||||
mv $(TAR_FILE) $(SHA256_FILE) $(DETACHED_SIG_FILE) releases
|
||||
$(MAKE) VERSION=$(VERSION) release-message > $(PACKAGE)-$(VERSION).announce
|
||||
ifeq ($(REALLY_UPLOAD),yes)
|
||||
git push origin $(VERSION) $(DEB_TAG) release pristine-tar
|
||||
git push origin $(VERSION) release pristine-tar
|
||||
cd releases && scp $(TAR_FILE) $(SHA256_FILE) $(DETACHED_SIG_FILE) $(RELEASE_HOST):$(RELEASE_DIR)
|
||||
ssh $(RELEASE_HOST) "rm -f $(RELEASE_DIR)/LATEST-$(PACKAGE)-* ; ln -s $(TAR_FILE) $(RELEASE_DIR)/LATEST-$(TAR_FILE)"
|
||||
rsync --verbose --delete --recursive doc/_build/html/ $(RELEASE_HOST):$(DOC_DIR)
|
||||
|
@ -90,7 +89,6 @@ pre-release:
|
|||
$(MAKE) VERSION=$(VERSION) clean
|
||||
$(MAKE) VERSION=$(VERSION) test
|
||||
git tag -s -m "$(PACKAGE) $(VERSION) release" $(UPSTREAM_TAG)
|
||||
git tag -s -m "$(PACKAGE) Debian $(VERSION)-1 upload (same as $(VERSION))" $(DEB_TAG)
|
||||
$(MAKE) VERSION=$(VERSION) $(SHA256_FILE) $(DETACHED_SIG_FILE)
|
||||
ln -sf $(TAR_FILE) $(DEB_TAR_FILE)
|
||||
pristine-tar commit $(DEB_TAR_FILE) $(UPSTREAM_TAG)
|
||||
|
|
18
NEWS
18
NEWS
|
@ -1,3 +1,21 @@
|
|||
Notmuch 0.31.3 (2020-12-25)
|
||||
===========================
|
||||
|
||||
Bindings
|
||||
--------
|
||||
|
||||
Fix for exclude tags in notmuch2 bindings.
|
||||
|
||||
Build
|
||||
-----
|
||||
|
||||
Portability update for T360-symbol-hiding
|
||||
|
||||
Library
|
||||
-------
|
||||
|
||||
Fix for memory error in notmuch_database_get_config_list
|
||||
|
||||
Notmuch 0.31.2 (2020-11-08)
|
||||
===========================
|
||||
|
||||
|
|
|
@ -578,7 +578,7 @@ class Database(base.NotmuchObject):
|
|||
if exclude_tags is not None:
|
||||
for tag in exclude_tags:
|
||||
if isinstance(tag, str):
|
||||
tag = str.encode('utf-8')
|
||||
tag = tag.encode('utf-8')
|
||||
capi.lib.notmuch_query_add_tag_exclude(query_p, tag)
|
||||
return querymod.Query(self, query_p)
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
0.31.2
|
||||
0.31.3
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
# this file should be kept in sync with ../../../version
|
||||
__VERSION__ = '0.31.2'
|
||||
__VERSION__ = '0.31.3'
|
||||
SOVERSION = '5'
|
||||
|
|
9
debian/changelog
vendored
9
debian/changelog
vendored
|
@ -1,3 +1,12 @@
|
|||
notmuch (0.31.3-1) unstable; urgency=medium
|
||||
|
||||
* New upstream bugfix release
|
||||
* Second fix for T360, fix regression on ppc64el
|
||||
* Fix for exclude tags in notmuch2 python bindings
|
||||
* Fix for memory error in notmuch_database_get_config_list
|
||||
|
||||
-- David Bremner <bremner@debian.org> Fri, 25 Dec 2020 11:48:37 -0400
|
||||
|
||||
notmuch (0.31.2-5) unstable; urgency=medium
|
||||
|
||||
* Use readelf instead of nm in T360, hopefully build in ppc64
|
||||
|
|
59
debian/patches/debian-changes
vendored
59
debian/patches/debian-changes
vendored
|
@ -3,28 +3,45 @@ delta against upstream is either kept as a single patch, or maintained
|
|||
in some VCS, and exported as a single patch instead of more manageable
|
||||
atomic patches.
|
||||
|
||||
--- notmuch-0.31.2.orig/doc/Makefile.local
|
||||
+++ notmuch-0.31.2/doc/Makefile.local
|
||||
@@ -43,7 +43,7 @@ INFO_INFO_FILES := $(INFO_TEXI_FILES:.te
|
||||
rm -f $@ && gzip --no-name --stdout $^ > $@
|
||||
|
||||
ifeq ($(WITH_EMACS),1)
|
||||
-$(DOCBUILDDIR)/.roff.stamp sphinx-html sphinx-texinfo: docstring.stamp
|
||||
+$(DOCBUILDDIR)/.roff.stamp $(DOCBUILDDIR)/.html.stamp $(DOCBUILDDIR)/.texi.stamp : docstring.stamp
|
||||
--- notmuch-0.31.3.orig/Makefile.global
|
||||
+++ notmuch-0.31.3/Makefile.global
|
||||
@@ -36,7 +36,6 @@ endif
|
||||
endif
|
||||
|
||||
sphinx-html: $(DOCBUILDDIR)/.html.stamp
|
||||
--- notmuch-0.31.2.orig/test/T360-symbol-hiding.sh
|
||||
+++ notmuch-0.31.2/test/T360-symbol-hiding.sh
|
||||
@@ -26,8 +26,9 @@ test_begin_subtest 'checking output'
|
||||
test_expect_equal "$result" "$output"
|
||||
UPSTREAM_TAG=$(subst ~,_,$(VERSION))
|
||||
-DEB_TAG=debian/$(UPSTREAM_TAG)-1
|
||||
|
||||
test_begin_subtest 'comparing existing to exported symbols'
|
||||
-nm -P $NOTMUCH_BUILDDIR/lib/libnotmuch.so | awk '$2 == "T" && $1 ~ "^notmuch" {print $1}' | sort | uniq > ACTUAL
|
||||
-sed -n 's/^\(notmuch_[a-zA-Z0-9_]*\)[[:blank:]]*(.*/\1/p' $NOTMUCH_SRCDIR/lib/notmuch.h | sort | uniq > EXPORTED
|
||||
+readelf -Ws $NOTMUCH_BUILDDIR/lib/libnotmuch.so | \
|
||||
+ awk '$4 == "FUNC" && $5 == "GLOBAL" && $7 != "UND" {print $8}' | sort -u > ACTUAL
|
||||
+sed -n 's/^\(notmuch_[a-zA-Z0-9_]*\)[[:blank:]]*(.*/\1/p' $NOTMUCH_SRCDIR/lib/notmuch.h | sort -u > EXPORTED
|
||||
test_expect_equal_file EXPORTED ACTUAL
|
||||
RELEASE_HOST=notmuchmail.org
|
||||
RELEASE_DIR=/srv/notmuchmail.org/www/releases
|
||||
--- notmuch-0.31.3.orig/Makefile.local
|
||||
+++ notmuch-0.31.3/Makefile.local
|
||||
@@ -73,12 +73,11 @@ release: verify-source-tree-and-version
|
||||
$(MAKE) VERSION=$(VERSION) $(SHA256_FILE) $(DETACHED_SIG_FILE)
|
||||
ln -sf $(TAR_FILE) $(DEB_TAR_FILE)
|
||||
pristine-tar commit $(DEB_TAR_FILE) $(UPSTREAM_TAG)
|
||||
- git tag -s -m "$(PACKAGE) Debian $(VERSION)-1 upload (same as $(VERSION))" $(DEB_TAG)
|
||||
mkdir -p releases
|
||||
mv $(TAR_FILE) $(SHA256_FILE) $(DETACHED_SIG_FILE) releases
|
||||
$(MAKE) VERSION=$(VERSION) release-message > $(PACKAGE)-$(VERSION).announce
|
||||
ifeq ($(REALLY_UPLOAD),yes)
|
||||
- git push origin $(VERSION) $(DEB_TAG) release pristine-tar
|
||||
+ git push origin $(VERSION) release pristine-tar
|
||||
cd releases && scp $(TAR_FILE) $(SHA256_FILE) $(DETACHED_SIG_FILE) $(RELEASE_HOST):$(RELEASE_DIR)
|
||||
ssh $(RELEASE_HOST) "rm -f $(RELEASE_DIR)/LATEST-$(PACKAGE)-* ; ln -s $(TAR_FILE) $(RELEASE_DIR)/LATEST-$(TAR_FILE)"
|
||||
rsync --verbose --delete --recursive doc/_build/html/ $(RELEASE_HOST):$(DOC_DIR)
|
||||
@@ -90,7 +89,6 @@ pre-release:
|
||||
$(MAKE) VERSION=$(VERSION) clean
|
||||
$(MAKE) VERSION=$(VERSION) test
|
||||
git tag -s -m "$(PACKAGE) $(VERSION) release" $(UPSTREAM_TAG)
|
||||
- git tag -s -m "$(PACKAGE) Debian $(VERSION)-1 upload (same as $(VERSION))" $(DEB_TAG)
|
||||
$(MAKE) VERSION=$(VERSION) $(SHA256_FILE) $(DETACHED_SIG_FILE)
|
||||
ln -sf $(TAR_FILE) $(DEB_TAR_FILE)
|
||||
pristine-tar commit $(DEB_TAR_FILE) $(UPSTREAM_TAG)
|
||||
--- notmuch-0.31.3.orig/NEWS
|
||||
+++ notmuch-0.31.3/NEWS
|
||||
@@ -1,4 +1,5 @@
|
||||
Notmuch 0.31.3 (2020-12-25)
|
||||
+===========================
|
||||
|
||||
test_done
|
||||
Bindings
|
||||
--------
|
||||
|
|
|
@ -26,7 +26,7 @@ test_begin_subtest 'checking output'
|
|||
test_expect_equal "$result" "$output"
|
||||
|
||||
test_begin_subtest 'comparing existing to exported symbols'
|
||||
readelf -Ws $NOTMUCH_BUILDDIR/lib/libnotmuch.so | \
|
||||
readelf -Ws $NOTMUCH_BUILDDIR/lib/libnotmuch.so | sed -e 's/\[[^]]*\]//' |\
|
||||
awk '$4 == "FUNC" && $5 == "GLOBAL" && $7 != "UND" {print $8}' | sort -u > ACTUAL
|
||||
sed -n 's/^\(notmuch_[a-zA-Z0-9_]*\)[[:blank:]]*(.*/\1/p' $NOTMUCH_SRCDIR/lib/notmuch.h | sort -u > EXPORTED
|
||||
test_expect_equal_file EXPORTED ACTUAL
|
||||
|
|
|
@ -1 +1 @@
|
|||
0.31.2
|
||||
0.31.3
|
||||
|
|
Loading…
Reference in a new issue