mirror of
https://git.notmuchmail.org/git/notmuch
synced 2024-11-24 20:08:10 +01:00
Merge remote-tracking branch 'origin/debian/bullseye' into release
This commit is contained in:
commit
9d6f4641d1
3 changed files with 146 additions and 0 deletions
9
debian/changelog
vendored
9
debian/changelog
vendored
|
@ -44,6 +44,15 @@ notmuch (0.32~rc1-1) experimental; urgency=medium
|
|||
|
||||
-- David Bremner <bremner@debian.org> Sat, 24 Apr 2021 12:46:10 -0300
|
||||
|
||||
notmuch (0.31.4-2) unstable; urgency=medium
|
||||
|
||||
* Cherry pick upstream commit 3f4de98e7c8, which fixes a bug where
|
||||
duplicate message-ids can cause multiple thread-ids for some message
|
||||
documents.
|
||||
* Add build-dependency on xapian-tools, for new test
|
||||
|
||||
-- David Bremner <bremner@debian.org> Mon, 28 Jun 2021 22:48:02 -0300
|
||||
|
||||
notmuch (0.31.4-1) unstable; urgency=medium
|
||||
|
||||
* New upstream bugfix release
|
||||
|
|
136
debian/patches/debian-changes
vendored
Normal file
136
debian/patches/debian-changes
vendored
Normal file
|
@ -0,0 +1,136 @@
|
|||
This is an autogenerated patch header for a single-debian-patch file. The
|
||||
delta against upstream is either kept as a single patch, or maintained
|
||||
in some VCS, and exported as a single patch instead of more manageable
|
||||
atomic patches.
|
||||
|
||||
--- notmuch-0.31.4.orig/lib/add-message.cc
|
||||
+++ notmuch-0.31.4/lib/add-message.cc
|
||||
@@ -407,14 +407,17 @@ static notmuch_status_t
|
||||
_notmuch_database_link_message (notmuch_database_t *notmuch,
|
||||
notmuch_message_t *message,
|
||||
notmuch_message_file_t *message_file,
|
||||
- bool is_ghost)
|
||||
+ bool is_ghost,
|
||||
+ bool is_new)
|
||||
{
|
||||
void *local = talloc_new (NULL);
|
||||
notmuch_status_t status;
|
||||
const char *thread_id = NULL;
|
||||
|
||||
/* Check if the message already had a thread ID */
|
||||
- if (notmuch->features & NOTMUCH_FEATURE_GHOSTS) {
|
||||
+ if (! is_new) {
|
||||
+ thread_id = notmuch_message_get_thread_id (message);
|
||||
+ } else if (notmuch->features & NOTMUCH_FEATURE_GHOSTS) {
|
||||
if (is_ghost)
|
||||
thread_id = notmuch_message_get_thread_id (message);
|
||||
} else {
|
||||
@@ -539,7 +542,7 @@ notmuch_database_index_file (notmuch_dat
|
||||
}
|
||||
|
||||
ret = _notmuch_database_link_message (notmuch, message,
|
||||
- message_file, is_ghost);
|
||||
+ message_file, is_ghost, is_new);
|
||||
if (ret)
|
||||
goto DONE;
|
||||
|
||||
--- notmuch-0.31.4.orig/test/T357-index-decryption.sh
|
||||
+++ notmuch-0.31.4/test/T357-index-decryption.sh
|
||||
@@ -112,12 +112,10 @@ test_expect_equal \
|
||||
"$expected"
|
||||
|
||||
# try inserting it with decryption, should appear as a single copy
|
||||
-# (note: i think thread id skips 4 because of duplicate message-id
|
||||
-# insertion, above)
|
||||
test_begin_subtest "message cleartext is present with insert --decrypt=true"
|
||||
notmuch insert --folder=sent --decrypt=true <<<"$contents"
|
||||
-output=$(notmuch search wumpus)
|
||||
-expected='thread:0000000000000005 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (encrypted inbox unread)'
|
||||
+output=$(notmuch search wumpus | notmuch_search_sanitize)
|
||||
+expected='thread:XXX 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (encrypted inbox unread)'
|
||||
test_expect_equal \
|
||||
"$output" \
|
||||
"$expected"
|
||||
@@ -127,9 +125,9 @@ test_expect_equal \
|
||||
test_begin_subtest 'tagging all messages'
|
||||
test_expect_success 'notmuch tag +blarney "encrypted message"'
|
||||
test_begin_subtest "verify that tags have not changed"
|
||||
-output=$(notmuch search tag:blarney)
|
||||
-expected='thread:0000000000000001 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 001 (blarney encrypted inbox)
|
||||
-thread:0000000000000005 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (blarney encrypted inbox unread)'
|
||||
+output=$(notmuch search tag:blarney | notmuch_search_sanitize)
|
||||
+expected='thread:XXX 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 001 (blarney encrypted inbox)
|
||||
+thread:XXX 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (blarney encrypted inbox unread)'
|
||||
test_expect_equal \
|
||||
"$output" \
|
||||
"$expected"
|
||||
@@ -138,14 +136,14 @@ test_expect_equal \
|
||||
test_begin_subtest 'reindex old messages'
|
||||
test_expect_success 'notmuch reindex --decrypt=true tag:encrypted and not property:index.decryption=success'
|
||||
test_begin_subtest "reindexed encrypted message, including cleartext"
|
||||
-output=$(notmuch search wumpus)
|
||||
+output=$(notmuch search wumpus | notmuch_search_sanitize)
|
||||
test_expect_equal \
|
||||
"$output" \
|
||||
"$expected"
|
||||
|
||||
# and the same search, but by property ($expected is untouched):
|
||||
test_begin_subtest "emacs search by property for both messages"
|
||||
-output=$(notmuch search property:index.decryption=success)
|
||||
+output=$(notmuch search property:index.decryption=success | notmuch_search_sanitize)
|
||||
test_expect_equal \
|
||||
"$output" \
|
||||
"$expected"
|
||||
@@ -154,7 +152,7 @@ test_expect_equal \
|
||||
test_begin_subtest 'reindex in auto mode'
|
||||
test_expect_success 'notmuch reindex tag:encrypted and property:index.decryption=success'
|
||||
test_begin_subtest "reindexed encrypted messages, should not have changed"
|
||||
-output=$(notmuch search wumpus)
|
||||
+output=$(notmuch search wumpus | notmuch_search_sanitize)
|
||||
test_expect_equal \
|
||||
"$output" \
|
||||
"$expected"
|
||||
@@ -188,9 +186,9 @@ test_expect_equal \
|
||||
|
||||
# ensure that the tags remain even when we are dropping the cleartext.
|
||||
test_begin_subtest "verify that tags remain without cleartext"
|
||||
-output=$(notmuch search tag:blarney)
|
||||
-expected='thread:0000000000000001 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 001 (blarney encrypted inbox)
|
||||
-thread:0000000000000005 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (blarney encrypted inbox unread)'
|
||||
+output=$(notmuch search tag:blarney | notmuch_search_sanitize)
|
||||
+expected='thread:XXX 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 001 (blarney encrypted inbox)
|
||||
+thread:XXX 2000-01-01 [1/1] Notmuch Test Suite; test encrypted message for cleartext index 002 (blarney encrypted inbox unread)'
|
||||
test_expect_equal \
|
||||
"$output" \
|
||||
"$expected"
|
||||
@@ -199,7 +197,7 @@ test_begin_subtest "index cleartext with
|
||||
test_expect_success "notmuch reindex --decrypt=nostash tag:blarney"
|
||||
|
||||
test_begin_subtest "Ensure that the indexed terms are present"
|
||||
-output=$(notmuch search wumpus)
|
||||
+output=$(notmuch search wumpus | notmuch_search_sanitize)
|
||||
test_expect_equal \
|
||||
"$output" \
|
||||
"$expected"
|
||||
--- notmuch-0.31.4.orig/test/T670-duplicate-mid.sh
|
||||
+++ notmuch-0.31.4/test/T670-duplicate-mid.sh
|
||||
@@ -6,6 +6,19 @@ add_message '[id]="duplicate"' '[subject
|
||||
add_message '[id]="duplicate"' '[subject]="message 2" [filename]=copy2'
|
||||
|
||||
add_message '[id]="duplicate"' '[subject]="message 0" [filename]=copy0'
|
||||
+
|
||||
+test_begin_subtest 'at most 1 thread-id per xapian document'
|
||||
+db=${MAIL_DIR}/.notmuch/xapian
|
||||
+for doc in $(xapian-delve -1 -t '' "$db" | grep '^[1-9]'); do
|
||||
+ xapian-delve -1 -r "$doc" "$db" | grep -c '^G'
|
||||
+done > OUTPUT.raw
|
||||
+sort -u < OUTPUT.raw > OUTPUT
|
||||
+cat <<EOF > EXPECTED
|
||||
+0
|
||||
+1
|
||||
+EOF
|
||||
+test_expect_equal_file EXPECTED OUTPUT
|
||||
+
|
||||
test_begin_subtest 'search: first indexed subject preserved'
|
||||
cat <<EOF > EXPECTED
|
||||
thread:XXX 2001-01-05 [1/1(3)] Notmuch Test Suite; message 1 (inbox unread)
|
1
debian/patches/series
vendored
Normal file
1
debian/patches/series
vendored
Normal file
|
@ -0,0 +1 @@
|
|||
debian-changes
|
Loading…
Reference in a new issue