mirror of
https://git.notmuchmail.org/git/notmuch
synced 2024-11-28 21:54:10 +01:00
Commit Debian 3.0 (quilt) metadata
[dgit (9.12) quilt-fixup]
This commit is contained in:
parent
40b75f50be
commit
c5504cb043
2 changed files with 35 additions and 0 deletions
34
debian/patches/debian-changes
vendored
Normal file
34
debian/patches/debian-changes
vendored
Normal file
|
@ -0,0 +1,34 @@
|
||||||
|
This is an autogenerated patch header for a single-debian-patch file. The
|
||||||
|
delta against upstream is either kept as a single patch, or maintained
|
||||||
|
in some VCS, and exported as a single patch instead of more manageable
|
||||||
|
atomic patches.
|
||||||
|
|
||||||
|
--- notmuch-0.31.1.orig/devel/release-checks.sh
|
||||||
|
+++ notmuch-0.31.1/devel/release-checks.sh
|
||||||
|
@@ -29,7 +29,7 @@ append_emsg ()
|
||||||
|
emsgs="${emsgs:+$emsgs\n} $1"
|
||||||
|
}
|
||||||
|
|
||||||
|
-for f in ./version debian/changelog NEWS "$PV_FILE"
|
||||||
|
+for f in ./version.txt debian/changelog NEWS "$PV_FILE"
|
||||||
|
do
|
||||||
|
if [ ! -f "$f" ]; then append_emsg "File '$f' is missing"
|
||||||
|
elif [ ! -r "$f" ]; then append_emsg "File '$f' is unreadable"
|
||||||
|
@@ -53,7 +53,7 @@ then
|
||||||
|
else
|
||||||
|
echo "Reading './version' file failed (surprisingly!)"
|
||||||
|
exit 1
|
||||||
|
-fi < ./version
|
||||||
|
+fi < ./version.txt
|
||||||
|
|
||||||
|
readonly VERSION
|
||||||
|
|
||||||
|
@@ -109,7 +109,7 @@ else
|
||||||
|
fi
|
||||||
|
|
||||||
|
echo -n "Checking that python bindings version is $VERSION... "
|
||||||
|
-py_version=`python -c "with open('$PV_FILE') as vf: exec(vf.read()); print(__VERSION__)"`
|
||||||
|
+py_version=`python3 -c "with open('$PV_FILE') as vf: exec(vf.read()); print(__VERSION__)"`
|
||||||
|
if [ "$py_version" = "$VERSION" ]
|
||||||
|
then
|
||||||
|
echo Yes.
|
1
debian/patches/series
vendored
Normal file
1
debian/patches/series
vendored
Normal file
|
@ -0,0 +1 @@
|
||||||
|
debian-changes
|
Loading…
Reference in a new issue