From 82faa059b8c98a3af016778734be329557d4217d Mon Sep 17 00:00:00 2001
From: David Bremner <david@tethera.net>
Date: Fri, 11 Dec 2020 13:06:44 -0400
Subject: [PATCH 1/3] test/T360-symbol-hiding: use readelf in place of nm

It turns out that using nm -P isn't as portable as hoped. In
particular with some ELF ABIs (e.g. ppc64 ELFv1), the desired symbols
end up in the data section instead of text.

The test is currently only functional on ELF based architectures, so I
think it's legit to depend on readelf instead of nm.

The switch to readelf has the advantage that we can explicitely ask
for all of the symbols with global visibility, rather than grepping
for notmuch. That seems a more robust approach since it will catch any
strangely named global symbols.
---
 test/T360-symbol-hiding.sh | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/test/T360-symbol-hiding.sh b/test/T360-symbol-hiding.sh
index b34f1e54..3f00dd38 100755
--- a/test/T360-symbol-hiding.sh
+++ b/test/T360-symbol-hiding.sh
@@ -26,8 +26,9 @@ test_begin_subtest 'checking output'
 test_expect_equal "$result" "$output"
 
 test_begin_subtest 'comparing existing to exported symbols'
-nm -P $NOTMUCH_BUILDDIR/lib/libnotmuch.so | awk '$2 == "T" && $1 ~ "^notmuch" {print $1}' | sort | uniq > ACTUAL
-sed -n 's/^\(notmuch_[a-zA-Z0-9_]*\)[[:blank:]]*(.*/\1/p' $NOTMUCH_SRCDIR/lib/notmuch.h | sort | uniq > EXPORTED
+readelf -Ws $NOTMUCH_BUILDDIR/lib/libnotmuch.so | \
+    awk '$4 == "FUNC" && $5 == "GLOBAL" && $7 != "UND" {print $8}' | sort -u > ACTUAL
+sed -n 's/^\(notmuch_[a-zA-Z0-9_]*\)[[:blank:]]*(.*/\1/p' $NOTMUCH_SRCDIR/lib/notmuch.h | sort -u > EXPORTED
 test_expect_equal_file EXPORTED ACTUAL
 
 test_done

From 9ebfe9d6ca8b1528c788c715deb5cf43ad1f289f Mon Sep 17 00:00:00 2001
From: David Bremner <david@tethera.net>
Date: Sun, 13 Dec 2020 08:25:29 -0400
Subject: [PATCH 2/3] debian: changelog for 0.31.2-5

---
 debian/changelog | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/debian/changelog b/debian/changelog
index a8943124..8c157bc0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+notmuch (0.31.2-5) unstable; urgency=medium
+
+  * Use readelf instead of nm in T360, hopefully build in ppc64
+
+ -- David Bremner <bremner@debian.org>  Sun, 13 Dec 2020 08:24:23 -0400
+
 notmuch (0.31.2-4) unstable; urgency=medium
 
   * Move prerequisite to file targets from phony ones. Thanks to

From 17540b73e812d51777fd63709beb8e9be22e26b8 Mon Sep 17 00:00:00 2001
From: David Bremner <david@tethera.net>
Date: Sun, 13 Dec 2020 08:25:39 -0400
Subject: [PATCH 3/3] Commit Debian 3.0 (quilt) metadata

[dgit (9.12) quilt-fixup]
---
 debian/patches/debian-changes | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index 40ee7d00..3e6eefca 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -14,3 +14,17 @@ atomic patches.
  endif
  
  sphinx-html: $(DOCBUILDDIR)/.html.stamp
+--- notmuch-0.31.2.orig/test/T360-symbol-hiding.sh
++++ notmuch-0.31.2/test/T360-symbol-hiding.sh
+@@ -26,8 +26,9 @@ test_begin_subtest 'checking output'
+ test_expect_equal "$result" "$output"
+ 
+ test_begin_subtest 'comparing existing to exported symbols'
+-nm -P $NOTMUCH_BUILDDIR/lib/libnotmuch.so | awk '$2 == "T" && $1 ~ "^notmuch" {print $1}' | sort | uniq > ACTUAL
+-sed -n 's/^\(notmuch_[a-zA-Z0-9_]*\)[[:blank:]]*(.*/\1/p' $NOTMUCH_SRCDIR/lib/notmuch.h | sort | uniq > EXPORTED
++readelf -Ws $NOTMUCH_BUILDDIR/lib/libnotmuch.so | \
++    awk '$4 == "FUNC" && $5 == "GLOBAL" && $7 != "UND" {print $8}' | sort -u > ACTUAL
++sed -n 's/^\(notmuch_[a-zA-Z0-9_]*\)[[:blank:]]*(.*/\1/p' $NOTMUCH_SRCDIR/lib/notmuch.h | sort -u > EXPORTED
+ test_expect_equal_file EXPORTED ACTUAL
+ 
+ test_done