diff --git a/Makefile.local b/Makefile.local
index fed32c07..3f8f1d56 100644
--- a/Makefile.local
+++ b/Makefile.local
@@ -70,7 +70,9 @@ dist: $(TAR_FILE)
 # We invoke make recursively only to force ordering of our phony
 # targets in the case of parallel invocation of make (-j).
 .PHONY: release
-release: release-verify-newer
+release:
+	$(MAKE) test
+	$(MAKE) release-verify-newer
 	$(MAKE) release-upload
 	@echo "Please send a release announcement as follows:"
 	@echo ""
diff --git a/RELEASING b/RELEASING
index e9d3e4fc..5c9192c3 100644
--- a/RELEASING
+++ b/RELEASING
@@ -10,18 +10,7 @@ Here are the steps to follow to create a new notmuch release:
 	not mentioned there. If so, pleas add them, (and ask the
 	authors of the commits to update NEWS in the future).
 
-3) Verify that the notmuch test suite passes.
-
-	Currently this is by running:
-
-		./test/notmuch-test
-
-	And manually verifying that every test says PASS. We plan to
-	fix this to automatically check the results and even to
-	automatically run the test suite as part of a Makefile target
-	described below.
-
-4) Increment the libnotmuch library version in lib/Makefile.local
+3) Increment the libnotmuch library version in lib/Makefile.local
 
 	See the instructions there for how to increment it. The
 	command below can be useful for inspecting header-file changes
@@ -37,11 +26,13 @@ Here are the steps to follow to create a new notmuch release:
 
 	Commit this change.
 
-5) Run "make VERSION=X.Y release" which will perform the following steps:
+4) Run "make VERSION=X.Y release" which will perform the following steps:
 
    For the X.Y version, we'll generally just increment Y. But for
    major milestones of usability we're increment X as well.
 
+	* Compile the current notmuch code (aborting release if it fails)
+	* Run the notmuch test suite (aborting release if it fails)
 	* Check that the notmuch version consists of only two components
 	* Check that no release exists with the current version
 	* Verify that "make dist" completes successfully
@@ -58,9 +49,9 @@ Here are the steps to follow to create a new notmuch release:
 	* Push that tag
 	* Provide some text for the release announcement (see below).
 
-6) Increment the notmuch version by adding a .1 micro number, commit, and push.
+5) Increment the notmuch version by adding a .1 micro number, commit, and push.
 
-7) Send a message to notmuch@notmuchmail.org to announce the release.
+6) Send a message to notmuch@notmuchmail.org to announce the release.
 
 	Use the text provided from "make release" above, (if for some
 	reason you lose this message, "make release-message" prints