mirror of
https://git.notmuchmail.org/git/notmuch
synced 2024-11-22 10:58:10 +01:00
f6ec7ca78f
Now that we have maildir synchronization turned on by default, it's advantageous to make all of the tests exercise it as much as possible.
39 lines
1.4 KiB
Text
39 lines
1.4 KiB
Text
From: "Chris Wilson" <chris@chris-wilson.co.uk>
|
|
To: notmuch@notmuchmail.org
|
|
Date: Wed, 18 Nov 2009 11:34:54 +0000
|
|
Subject: [notmuch] [PATCH 1/2] Makefile: evaluate pkg-config once
|
|
Message-ID: <1258544095-16616-1-git-send-email-chris@chris-wilson.co.uk>
|
|
|
|
Currently the same `pkg-config ...` is executed for every target, so
|
|
just store the results in a variable.
|
|
---
|
|
Makefile | 9 +++++----
|
|
1 files changed, 5 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 96aaa73..023b2ec 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -4,15 +4,16 @@ CFLAGS=-O2
|
|
|
|
# Additional flags that we will append to whatever the user set.
|
|
# These aren't intended for the user to manipulate.
|
|
-extra_cflags = `pkg-config --cflags glib-2.0 gmime-2.4 talloc`
|
|
-extra_cxxflags = `xapian-config --cxxflags`
|
|
+extra_cflags := $(shell pkg-config --cflags glib-2.0 gmime-2.4 talloc)
|
|
+extra_cxxflags := $(shell xapian-config --cxxflags)
|
|
|
|
# Now smash together user's values with our extra values
|
|
override CFLAGS += $(WARN_FLAGS) $(extra_cflags)
|
|
override CXXFLAGS += $(WARN_FLAGS) $(extra_cflags) $(extra_cxxflags)
|
|
|
|
-override LDFLAGS += `pkg-config --libs glib-2.0 gmime-2.4 talloc` \
|
|
- `xapian-config --libs`
|
|
+override LDFLAGS += \
|
|
+ $(shell pkg-config --libs glib-2.0 gmime-2.4 talloc) \
|
|
+ $(shell xapian-config --libs)
|
|
|
|
# Include our local Makefile.local first so that its first target is default
|
|
include Makefile.local
|
|
--
|
|
1.6.5.2
|